Regresar a la página www.ComoCrearTuWeb.com
Resultados 1 al 9 de 9

Tema: NO se me ve igual en todos los navegadores. Por qué???

  1. #1
    Me va gustando esto... Habitante
    Fecha de Ingreso
    27 oct, 08
    Mensajes
    63
    Poder de Reputación
    17

    NO se me ve igual en todos los navegadores. Por qué???

    Hola a tod@s.

    Estoy ultimando mi web, pero no se me ve bien en todos los navegadores.
    En ie, se ve como se me tiene que ver, pero en firefox, chrome, y opera, no se ve bien. He estado trasteando por el foro y encontré el post de "conseguir que la web se vea igual en todos los navegadores", pues bien he hecho lo que se me indica y el resultado es peor de lo que ya tenía. Podría alguien echarme una mano, a ver qué es lo que he hecho mal???
    A parte tengo el problema de los desplegables, que se me abren por debajo de la página, no debajo justo de donde tiene que salir. (en opera, por ejemplo, no se me despliega nada)

    En la subsección centenario del desplegable historia (que se verá más abajo) he dejado los códigos que se indicaban en el post que mencioné anteriormente, para que vean la diferencia entre una página y las otras. Mi web es www.coopetrer.es


    Muchas gracias

    Saludos

    Charli

  2. #2
    Moderador CCTW Habitante
    Fecha de Ingreso
    12 ago, 07
    Ubicación
    Galicia (España)
    Mensajes
    3,351
    Poder de Reputación
    35
    Es imposible que se te ponga peor. Por favor, crea una sección (carpeta) de pruebas en tu web, haz las modificaciones oportunas que explico en ese tema del foro, sube los archivos a la zona de pruebas y nos lo enseñas, algo haces mal.

    Saludos

  3. #3
    Me va gustando esto... Habitante
    Fecha de Ingreso
    27 oct, 08
    Mensajes
    63
    Poder de Reputación
    17
    Hola otra vez.

    Foley, lo siento en el alma, pero he seguido los pasos que indicabas en el post general y se me sigue viendo peor (en ie, firefox, chrome y opera) que cuando no lo tenía. No sé qué he hecho mal, así que voy a pasarte el head de un código-html de una de las páginas (como son la gran mayoria iguales -excepto los textos-, con una sobra).

    Esto es lo que he puesto en el head del index.html :

    <head>
    <meta content="text/html; charset=iso-8859-1" http-equiv=Content-Type>
    <title>Prueba</title>
    <link rel="stylesheet" href="estilos.css" type="text/css" media="all">
    <link rel="stylesheet" href="estilo-menu-desplegable.css" type="text/css" media="all">
    <script language="javascript" src="no-tocar.txt" type="text/javascript"></script>
    <script language="javascript" src="numero-de-menus.txt" type="text/javascript"></script>


    <link rel="stylesheet" href="reset.css" media="all" />
    <link rel="stylesheet" href="estilos.css" media="all" />
    <!--[if IE]>
    <link rel="STYLESHEET" type="text/css" href="estilos-ie.css" />
    <![endif]-->

    </head>

    - En el archivo reset.css, he puesto lo que pone en el enlace del post
    - estilos.css, para firefox, opera, chrome, etc.
    - estilos-ie.css, para explorer.

    La web ya la podeis ver (la he vuelto a dejar como estaba, sin poner aquel código), y el tema está ahí, se ve bien en ie y mal en el resto.

    www.coopetrer.es

    Saludos y gracias

  4. #4
    Me va gustando esto... Habitante
    Fecha de Ingreso
    27 oct, 08
    Mensajes
    63
    Poder de Reputación
    17
    Hola a tod@s.

    Estoy haciendo mogollón de experimetos y probando muchas cosas, para intentar que se me vea bien en todos los navegadores, y no funciona nada. Creo que esto va a poder conmigo

    He hecho lo que ponía en el post: conseguir que la web se vea igual en todos los navegadores y lo que indicaba un enlace desde este: he hecho el reset, he creado una hoja de estilos para cada navegador, he quitado el reset, he puesto y quitado cosas, pero en ninguna de ellas he conseguido que en firefox se vea mejor que de lo actualmente se ve: están descuadradas, el título de la página aparece desplazdo a la derecha y el último div está desplazado a la izquierda aparte de que está por fuera del margen inferior.
    En ie y en opera sí que se ven bien. Y en google chrome casi se ven bien, hay una superposición de divs y el margen inferior no existe.

    QUÉ PUEDO HACER, ME PUEDE AYUDAR ALGUIEN????

    GRACIAS A TOD@S
    SALUDOS

  5. #5
    Recien Llegado! Pasaba por aquí...
    Fecha de Ingreso
    30 oct, 10
    Mensajes
    2
    Poder de Reputación
    0
    es problema del programa que uses creo yo

  6. #6
    Moderador CCTW Habitante
    Fecha de Ingreso
    12 ago, 07
    Ubicación
    Galicia (España)
    Mensajes
    3,351
    Poder de Reputación
    35
    El head debes dejarlo así:

    Código:
    <head>
    <meta content="text/html; charset=iso-8859-1" http-equiv=Content-Type>
    <title>Prueba</title>
    <script language="javascript" src="no-tocar.txt" type="text/javascript"></script>
    <script language="javascript" src="numero-de-menus.txt" type="text/javascript"></script>
    <link rel="stylesheet" href="reset.css" media="all" />
    <link rel="stylesheet" href="estilos.css" media="all" />
    <link rel="stylesheet" href="estilo-menu-desplegable.css" type="text/css" media="all">
    <!--[if IE]>
    <link rel="STYLESHEET" type="text/css" href="estilos-ie.css" />
    <![endif]-->
    
    </head>
    Saludos

  7. #7
    Recien Llegado! Habitual
    Fecha de Ingreso
    20 oct, 10
    Ubicación
    Las Palmas
    Mensajes
    11
    Poder de Reputación
    14
    uffffff,tengo el mismo problema,hice todo lo del curso y tengo ya la web terminada y la abro en chrome y sale desastrada.

    He hecho lo msimo que charly y se queda igual
    que gran pagina CCTW

  8. #8
    Me va gustando esto... Habitante
    Fecha de Ingreso
    27 oct, 08
    Mensajes
    63
    Poder de Reputación
    17
    Hola a tod@s.

    He puesto en mi head lo que me has indicado y el resultado ha sido el mismo que venía obteniendo en las pruebas que iba haciendo.
    He descubierto que la línea del reset <link rel="stylesheet" href="reset.css" media="all" /> es la que me deja todas las cosas peor de lo que estaban:
    (En firefox se ve igual [todo descuadrado] y en chrome tb [el div del título se sitúa encima de otro div], a parte de que el tamaño de los títulos disminuyen [en todos los navegadores]).

    Es normal??? Habría otra manera de hacerse??? Qué es lo que tengo mal en mis códigos??? Tendría que modificar algo en el reset que pasaste??? y si fuese así, qué tendría que modificar???

    Lamento ser tan pesado, pero es que estoy bloqueadísimo. :( :( y ya no sé qué más hacer.


    GRACIAS OTRA VEZ

    SALUDOS

  9. #9
    Me va gustando esto... Habitante
    Fecha de Ingreso
    27 oct, 08
    Mensajes
    63
    Poder de Reputación
    17
    Hola a tod@s.

    jdel54, cuando me dices que es problema del programa, a qué te refieres??? HAsta ahora he venido utilizando el mismo que recomendaban desde el curso CCTW.
    Gracias por tu colaboración.

    Un saludo

Temas Similares

  1. Respuestas: 62
    Último Mensaje: 19/08/2019, 16:10
  2. Tamaño de Fuentes igual para todos los navegadores
    Por Williams en el foro Todo sobre Estilos CSS
    Respuestas: 3
    Último Mensaje: 03/05/2008, 22:53

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •