Regresar a la página www.ComoCrearTuWeb.com
Resultados 1 al 7 de 7

Tema: ayuda configuracion phpbb3

  1. #1
    Me va gustando esto... Habitante
    Fecha de Ingreso
    05 mar, 08
    Mensajes
    62
    Poder de Reputación
    19

    ayuda configuracion phpbb3

    les cuento.

    Del tutorial de phpBB3 que hay en CCTW:

    Lo instale, lo configure, cambie los permisos de escritura que me pedía... todo perfecto!! peeeeero cuando ya estaba dentro del foro (en el panel de administracion) se me olvido borrar/renombrar la carpeta install (la que esta dentro del phpbb3) y me sali del foro... el caso es que ahora la he borrado del servidor pero si intento acceder mediante la direccion que creo que seria: http://futsalchamberi.comuv.com/phpBB3 pues me sale la pagina que podran ver... (vamos que no funciona por algo del config.php, o eso creo)

    PHP Error Message

    Warning: require(./config.php) [function.require]: failed to open stream: Permission denied in /home/a3480897/public_html/phpBB3/common.php on line 127

    Free Web Hosting

    PHP Error Message

    Fatal error: require() [function.require]: Failed opening required './config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a3480897/public_html/phpBB3/common.php on line 127

    Free Web Hosting



    He intentado acceder al panel de administracion del foro o volver a instalarlo pero si pongo lo que jorgens dice que pongamos para instalarlo por primera (http://nombredemipaginaweb/phpBB3/ vez me sale lo mismo... vamos que no se que hacer.

    supongo que con 000webhost se podra poner este tipo de foro no?? porque al hacer el test lo hubiera detectado no??

    Si alguien me puede echar una mano, se lo agradeceria.

    Un saludo

  2. #2
    Me va gustando esto... Habitante
    Fecha de Ingreso
    05 mar, 08
    Mensajes
    62
    Poder de Reputación
    19
    Ya lo he arreglado!!!

    Ahora tengo dos dudas mas:

    1.- ponerlo en castellano
    2.- poner mi logo

    se puede hacer?? Como??
    Gracias

  3. #3
    Me va gustando esto... Habitante
    Fecha de Ingreso
    04 ene, 09
    Mensajes
    245
    Poder de Reputación
    18
    PAra poner en castellano entra ala pagina oficial de php

    y el logo pon uno ke tu quieras con nombre site_logo.png dendro de la carpeta ucp/images

    saludos

  4. #4
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    24 mar, 07
    Ubicación
    España
    Mensajes
    627
    Poder de Reputación
    23
    seccion Tutoriales varios:
    http://www.comocreartuweb.com/phpBB2/ftopic9806.html

    en ese tuto al final viene cómo traducir el foro a español.

    para el logo veo que ya has sustituido la imagen, pero al ser de distinto tamaño queda apretada.
    para arreglarlo, ve a la carpeta template dentro de styles/prosiver y edita el archivo overall_header.htm

    en ese archivo está el código correspondiente a la cabecera de tu foro. tienes que cambiar las dimensiones en pixels que vienen y poner las de tu nueva imagen.

    a lo mejor te resulta un poco complicado pero el código no es tan extenso ya verás.

  5. #5
    Me va gustando esto... Habitante
    Fecha de Ingreso
    05 mar, 08
    Mensajes
    62
    Poder de Reputación
    19
    gracias salmarina, pero el zip del link de descarga me no puedo descomprir porque dice que esta dañado... :(

    si me lo puedes pasar de otro modo (mira a ver si me lo puedes pasar en .rar [por probar], o darme otro link...) te lo agradeceria. Espera que ahora te pongo la parrafada del overall_header (en el siguiente post) vamos poco a poco... que es el primer foro que configuro y no tengo ni idea!!

    Muchas Gracias.

    Un saludo

  6. #6
    Me va gustando esto... Habitante
    Fecha de Ingreso
    05 mar, 08
    Mensajes
    62
    Poder de Reputación
    19
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="{S_CONTENT_DIRECTION}" lang="{S_USER_LANG}" xml:lang="{S_USER_LANG}">
    <head>

    <meta http-equiv="content-type" content="text/html; charset={S_CONTENT_ENCODING}" />
    <meta http-equiv="content-style-type" content="text/css" />
    <meta http-equiv="content-language" content="{S_USER_LANG}" />
    <meta http-equiv="imagetoolbar" content="no" />
    <meta name="resource-type" content="document" />
    <meta name="distribution" content="global" />
    <meta name="copyright" content="2000, 2002, 2005, 2007 phpBB Group" />
    <meta name="keywords" content="" />
    <meta name="description" content="" />
    {META}
    <title>{SITENAME} &bull; {L_MCP} &bull; {L_UCP} &bull; {PAGE_TITLE}</title>

    <!--
    phpBB style name: prosilver
    Based on style: prosilver (this is the default phpBB3 style)
    Original author: Tom Beddard ( http://www.subBlue.com/ )
    Modified by:

    NOTE: This page was generated by phpBB, the free open-source bulletin board package.
    The phpBB Group is not responsible for the content of this page and forum. For more information
    about phpBB please visit http://www.phpbb.com
    -->

    <script type="text/javascript">
    // <![CDATA[
    var jump_page = '{LA_JUMP_PAGE}:';
    var on_page = '{ON_PAGE}';
    var per_page = '{PER_PAGE}';
    var base_url = '{A_BASE_URL}';
    var style_cookie = 'phpBBstyle';
    var style_cookie_settings = '{A_COOKIE_SETTINGS}';
    var onload_functions = new Array();
    var onunload_functions = new Array();


    if ({S_NEW_PM})
    {
    var url = '{UA_POPUP_PM}';
    window.open(url.replace(/&amp;/g, '&'), '_phpbbprivmsg', 'height=225,resizable=yes,scrollbars=yes, width=400');
    }


    /**
    * Find a member
    */
    function find_username(url)
    {
    popup(url, 760, 570, '_usersearch');
    return false;
    }

    /**
    * New function for handling multiple calls to window.onload and window.unload by pentapenguin
    */
    window.onload = function()
    {
    for (var i = 0; i < onload_functions.length; i++)
    {
    eval(onload_functions[i]);
    }
    }

    window.onunload = function()
    {
    for (var i = 0; i < onunload_functions.length; i++)
    {
    eval(onunload_functions[i]);
    }
    }

    // ]]>
    </script>
    <script type="text/javascript" src="{T_TEMPLATE_PATH}/styleswitcher.js"></script>
    <script type="text/javascript" src="{T_TEMPLATE_PATH}/forum_fn.js"></script>

    <link href="{T_THEME_PATH}/print.css" rel="stylesheet" type="text/css" media="print" title="printonly" />
    <link href="{T_STYLESHEET_LINK}" rel="stylesheet" type="text/css" media="screen, projection" />

    <link href="{T_THEME_PATH}/normal.css" rel="stylesheet" type="text/css" title="A" />
    <link href="{T_THEME_PATH}/medium.css" rel="alternate stylesheet" type="text/css" title="A+" />
    <link href="{T_THEME_PATH}/large.css" rel="alternate stylesheet" type="text/css" title="A++" />


    <link href="{T_THEME_PATH}/bidi.css" rel="stylesheet" type="text/css" media="screen, projection" />


    </head>

    <body id="phpbb" class="section-{SCRIPT_NAME} {S_CONTENT_DIRECTION}">

    <div id="wrap">
    <a id="top" name="top" accesskey="t"></a>
    <div id="page-header">
    <div class="headerbar">
    <div class="inner"><span class="corners-top"><span></span></span>

    <div id="site-description">
    {SITE_LOGO_IMG}
    <h1>{SITENAME}</h1>


    {SITE_DESCRIPTION}</p>
    <p style="display: none;">{L_SKIP}</p>
    </div>


    <div id="search-box">
    <form action="{U_SEARCH}" method="post" id="search">
    <fieldset>
    <input name="keywords" id="keywords" type="text" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search" value="{SEARCH_WORDS}{L_SEARCH_MINI}" onclick="if(this.value=='{LA_SEARCH_MINI}')this.va lue='';" onblur="if(this.value=='')this.value='{LA_SEARCH_M INI}';" />
    <input class="button2" value="{L_SEARCH}" type="submit" />

    {L_SEARCH_ADV} {S_SEARCH_HIDDEN_FIELDS}
    </fieldset>
    </form>
    </div>


    <span class="corners-bottom"><span></span></span></div>
    </div>

    <div class="navbar">
    <div class="inner"><span class="corners-top"><span></span></span>

    <ul class="linklist navlinks">
    <li class="icon-home">{L_INDEX} {navlinks.FORUM_NAME}

    <li class="rightside">{L_CHANGE_FONT_SIZE}

    <li class="rightside">{L_EMAIL_TOPIC}
    <li class="rightside">{L_EMAIL_PM}
    <li class="rightside">{L_PRINT_TOPIC}
    <li class="rightside">{L_PRINT_PM}
    [/list]


    <ul class="linklist leftside">
    <li class="icon-ucp">
    {L_PROFILE}
    ({PRIVATE_MESSAGE_INFO}) &bull;
    {L_SEARCH_SELF}
    &bull;
    {L_RESTORE_PERMISSIONS}


    [/list]


    <ul class="linklist rightside">
    <li class="icon-faq">{L_FAQ}

    <li class="icon-members">{L_MEMBERLIST}
    <li class="icon-register">{L_REGISTER}
    <li class="icon-logout">{L_LOGIN_LOGOUT}

    [/list]

    <span class="corners-bottom"><span></span></span></div>
    </div>

    </div>

    <a name="start_here"></a>
    <div id="page-body">


    <div id="message" class="rules">
    <div class="inner"><span class="corners-top"><span></span></span>
    {L_INFORMATION}: {L_BOARD_DISABLED}
    <span class="corners-bottom"><span></span></span></div>
    </div>

    -------------------------------------------------------------------------------------

    AHORA MIS PREGUNTAS:
    1.- Si yo cambio lo que he puesto en negrita... no me aparece!! ¿porque??
    2.- por ejemplo {SITENAME} no existe en otra parte del codigo fuente, a no ser que este llamando a estilos, que ya no lo se. pero porque va entre {}??
    3.- Si se supone que las medidas estan en esta pagina debo ser muy torpe (seguro) porque no las veo y llevo un buen tiempo buscandolas para modificarlas...

    Muchas gracias por leeros los tochazos que pongo y por vuestras ayudas!!

    Un saludo

  7. #7
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    24 mar, 07
    Ubicación
    España
    Mensajes
    627
    Poder de Reputación
    23
    lo que aparece entre llaves { } son variables, sitename es el nombre del sitio, sitelogo el logo de tu sitio etc.
    en el caso de la plantilla prosilver las dimensiones no están en ese documento, están en:
    phpBB3/styles/prosilver/imageset/imageset.cfg

    en ese archivo encontrarás esto: (ábrelo con el bloc de notas por ejemplo)
    Código:
    # Images
    img_site_logo = site_logo.gif*52*139
    site_logo.gif es tu logotipo, y los números que vienen despues son el alto y ancho de ese logotipo. seguramente al cambiar esos valores y pones las dimensiones reales de tu nuevo logo arreglarás el problema.

    así que nada olvídate de el overall_header, eso ha sido error mío, no suelo usar la plantilla prosilver
    ______________________________________

    el zip para el idioma lo acabo de descargar y está perfectamente, si el tuyo está corrupto es porque se dañó al descargarlo. Bájalo de nuevo y funcionará bien.

Temas Similares

  1. ayuda con la configuracion
    Por chochi777 en el foro Foros
    Respuestas: 12
    Último Mensaje: 26/01/2009, 01:10
  2. configuracion dreamweaver ayuda
    Por gaditano20 en el foro Dreamweaver
    Respuestas: 0
    Último Mensaje: 20/06/2008, 03:16

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •