Regresar a la página www.ComoCrearTuWeb.com
Resultados 1 al 5 de 5

Tema: No recibo nada en mi correos

  1. #1
    Recien Llegado! Habitante
    Fecha de Ingreso
    07 abr, 08
    Ubicación
    sevilla
    Mensajes
    26
    Poder de Reputación
    18

    No recibo nada en mi correos

    hola a todos,
    Haber si entre todos podemos resolver mi problema,que la verdad se esta haciendo osesion.
    He seguido todas las formas que he leido,pero asi y todo,no resuelvo mi problema.
    .
    Mi index.html:(solo la parte que corresponde al formulario)
    <div id="contacto"> <h2>Contactar</h2> <form action="formulario.php" method="post" enctype="multipart/form-data" name="form1">
    <align="center" valign="top"><font color='#ff0000'></font>


    Nombre:
    <input name="nombre" type="text" class="campos" id="nombre" size="40" maxlength="60"> </p>



    Ciudad:
    <input name="ciudad" type="text" class="campos" id="ciudad" size="40" maxlength="60"> </p>


    Email:
    <input name="email" type="text" class="campos" id="email" size="40" maxlength="60"> </p>


    Consulta:
    <textarea name="consulta" " cols="30" rows="6" class="campos" id="consulta" ></textarea>

    <input name="button" type="submit" class="campos" id="button" value="Enviar ">
    </form> </div>

    Mi "formulario.php es igual que el index.html,pero agregando el php:
    <?php
    $sendTo = "alcantarilladosalcala@gmail.com";
    $subject = "primerformulario";
    $nombre = $_POST["nombre"];
    $mail = $_POST["mail"];
    $consulta = $_POST["consulta"];
    $headers .= "";
    $message = "\nNombre: " . $nombre . "\nmail: " . $mail . "\nconsulta: " . $consulta;
    mail($sendTo, $subject, $message, $headers);
    ?>
    esto lo hice para que no me devolviera una pagina en blanco,
    para mas informacion : uso debian testin,y tengo montado un servidor local con apache2 php5 y mysql5.0.
    Haber si podeis hecharme una mano,a mi me parece que sera cosa de configuracion del server,pero es que no se,gracias por adelantado,un desesperado,y no sera por no leerme todos los post de formularios,jejeje.

  2. #2
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    04 mar, 08
    Mensajes
    1,203
    Poder de Reputación
    24
    Tenemos un par de errores...

    mira aqui:


    <textarea name="consulta" " por que otras comillas quitalas para que quede asi: <textarea name="consulta"

    el e-mail lo tienes asi:
    <input name="email" type="text" class="campos" id="email" size="40" maxlength="60"> </p>

    le estas dando el nombre de e mail pero en el php pones:

    $mail = $_POST["mail"];

    deberias ponerlo asi:

    $mail = $_POST["email"];

    ahora esto que dices

    esto lo hice para que no me devolviera una pagina en blanco,
    no hiciste nada para que no se viera en blanco =S para que no te llege en blanco se hace esto:

    if ($nombre = ""){
    echo "debes poner tu nombre
    };
    elseif...

    asi con todos los campos

  3. #3
    Recien Llegado! Habitante
    Fecha de Ingreso
    07 abr, 08
    Ubicación
    sevilla
    Mensajes
    26
    Poder de Reputación
    18
    gracias likgl por tu ayuda,, sigo tus consejos,y posteo el resultado

  4. #4
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    04 mar, 08
    Mensajes
    1,203
    Poder de Reputación
    24
    OKI

  5. #5
    Recien Llegado! Habitante
    Fecha de Ingreso
    07 abr, 08
    Ubicación
    sevilla
    Mensajes
    26
    Poder de Reputación
    18

    culpa de mi servidor,

    hola,he robado como me dijiste,pero aun no recibo nada,he llagado a la conclusión que es problema de mi servidor,así que he optado por dejar el index.html solo y un links de contacto.
    Como es del trabajo,no necesito mucho,seguiré aprendiendo php ,y el formulario ya lo pondré en la web que me estoy montando.
    Gracias por todo,lo guardo para el futuro.

    http://www.alcantarillados.es es la de mi empresa,y la mia es http://www.akivaz.es (pero esta aun no esta en red).
    Doy por terminado pues el tema.

Temas Similares

  1. NO RECIBO NUMERO CLIENTE ID NI PASSWORD
    Por FORRES en el foro Problemas de Conexión con tu Servidor?
    Respuestas: 1
    Último Mensaje: 01/09/2009, 15:30

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •