Regresar a la página www.ComoCrearTuWeb.com
Resultados 1 al 7 de 7

Tema: Un problema con los frames (marcos)

  1. #1
    Me va gustando esto... Habitante Avatar de Polvorilla
    Fecha de Ingreso
    03 mar, 07
    Ubicación
    Barcelona
    Mensajes
    40
    Poder de Reputación
    21

    Un problema con los frames (marcos)

    Hola a tod@s.
    Tras mirar por todo el foro y no encontrar algo relativo a mi problema, me decido a exponerlo aquí para ver si alguien com más "claridad mental" que yo me puede decir donde está el "fallo".

    Veamos........... mi idea original es la de hacer una primera página con tres frames (o marcos) y que al hacer "klic" en cualquier enlace de la izquierda se habra el documento en el mainframe, y luego si hay enlaces en esta página, se habra en una ventana nueva.
    como se puede ver ............... algo tan fácil como eso.......... :?
    la cuestión es, que, cuando le doy al enlace de la izquierda el documento vinculado a el mainframe, se habre en una ventana nueva, en lugar de hacerlo en el marco que le "toca". :(
    Primero le puse unos botones FLASH para los enlaces..................... pensando que podría ser este el problema, los quité y puse solo texto, con esto, al hacer la prueba con el navegador (Iexplorer) desde el dreamWeaver me funciona................... pero al hacer la prueba directamente a traves de internet ............... no funciona.......
    Todo esto lo e hecho siguiendo el manual de Jorgens y algún otro que "pillé" por hai.
    He repasado una y otra vez lo de los vinculos, o sea, el nombre de documento y destino y me parecen correctos (según los manuales) por lo que no se ver donde puede estar el "error", o que he hecho mal.
    Por si alguien quiere "hecharle un vistazo" la he colgado aquí
    http://paco.bsdes.org
    Bueno ........ gracias por leerme...........

  2. #2
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    09 oct, 05
    Mensajes
    430
    Poder de Reputación
    25
    He probado tus enlaces y no se abren en ningún sitio, ni en el mainframe ni en página nueva excepto las fotos que ya le has puesto _blank, y con eso siempre se abrirá en una página nueva. Has subido esas páginas al servidor? Porque mirando el código, parece que los enlaces están bien... :?:

  3. #3
    Me va gustando esto... Habitante Avatar de Polvorilla
    Fecha de Ingreso
    03 mar, 07
    Ubicación
    Barcelona
    Mensajes
    40
    Poder de Reputación
    21

    Un problema con los frames (marcos) II

    Hola labruji.........
    Ante todo gracias por tu interes.

    Lo que me dices, es lo que me pasa ahora, despues de cambiar los botones por texto en los enlaces. Que no se habren en ningún sitio.

    las páginas estan en el servidor, todo lo que esta en el sitio local esta en el sitio remoto.

    Lo de las fotos, a mi desde casa aveces no me salen, solo salen los recuadros que dicen que ahi va una foto ( parece que no la encuentra)
    Pero desde otro sitio si que salen y funciona correctamente

    A veces pienso ......... que esto son cosas de los "duendes informaticos"

  4. #4
    Esto empieza a ser un vicio... Habitante
    Fecha de Ingreso
    09 oct, 05
    Mensajes
    430
    Poder de Reputación
    25
    Me rindo :?
    Lo he mirado y no encuentro el qué. Lo curioso que los enlaces si le das con el botón derecho del ratón y le dices abrir en página nueva si que lo hace pero en el j.... mainframe nop :? :?:
    Yo trabajo tb con marcos, pero solo con un marco flotante y nunca tengo problemas con los enlaces lo siento :?

  5. #5
    Me va gustando esto... Habitante Avatar de Polvorilla
    Fecha de Ingreso
    03 mar, 07
    Ubicación
    Barcelona
    Mensajes
    40
    Poder de Reputación
    21

    Un problema con los frames (marcos) III (solucionado)

    Hola labruji.........
    Ya he solucionado este problema ¡¡¡
    No se exactamente que es lo que le pasaba, pero despues de mirar y remirar me decidí por hacer la página otra vez de nuevo y sin botones Flash.
    Supongo que es lo que suele pasar a los novatos, cuando empezamos a cambiar cosas, ahora le pongo esto y ahora le quito esto otro etc. etc. y al final quedan unos códigos por haí dentro que no se sabe que hacen.

    bueno ............ hasta la proxima ........... nos leemos

  6. #6
    Administrador CCTW Webmaster de CCTWHabitante
    Fecha de Ingreso
    10 ago, 05
    Ubicación
    Cartagena, España
    Mensajes
    3,700
    Poder de Reputación
    10
    Veo que llego tarde.... je je. Pues si, a veces ponemos quitamos reponemos y requitamos y al final tenemos un montón de código que no sirve para nada dentro de la web y que nos produce algún error que nos vuelve un poco locos.

    Sobre todo pasa con los estilos. Definimos uno en la hoja de estilo, otros en el head, otros en la misma linea y al final no sabes nunca cual es el que está funcionando. Por eso es bueno aprender un poco de html, para poder eliminar lo que no nos hace falta.

    En cuanto a los enlaces, imagino que sabes que dentro del código del enlace, puedes señalar que el vínculo se abra en la misma página, en el mismo marco, en otro, etc, etc, colocando _blanck, _parent, etc, etc. Si no lo sabes nos lo dices y te indicamos, oki?

    Ale, un saludete!

  7. #7
    Me va gustando esto... Habitante Avatar de Polvorilla
    Fecha de Ingreso
    03 mar, 07
    Ubicación
    Barcelona
    Mensajes
    40
    Poder de Reputación
    21
    Hola Jorgens
    saludos :)
    De lo que me dices sobre los enlaces.............. pues si ....... lo se, ya me los miré y remiré por si habia algo mal puesto, pero no estaba haí el problema. :?

    Pero bueno ........ eso también nos sirve para aprender un poco más el html,

    Todo lo que estoy haciendo ahora son pruebas y aprendiendo, para que algún día me salga una página muy chula ......

    por lo que seguiré por aquí, leyendo....... y exponiendo las dudas que me surjan.........

    Bueno ....... saludos a la "peña"

Temas Similares

  1. Animar a marcos y frames
    Por RAPIDO en el foro Foro General
    Respuestas: 3
    Último Mensaje: 18/11/2007, 22:16
  2. Web con frames o marcos
    Por oscarveterinario en el foro Foro General
    Respuestas: 8
    Último Mensaje: 31/08/2007, 15:46

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •